Windows 8/8.1?

Home Forums [0] Redmoon Windows 8/8.1?

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #462
    Shades
    Participant

    Has anyone found a good way to run this on windows 8/8.1 short of creating a virtual machine?

    #463
    CynErr
    Participant

    Even on Windows 7 I use a Windows 2000 virtual machine for RM, the game itself creates a ton of CPU load for no good reason, I found running it inside a container made it much easier to run a number of clients simultaneously and to keep it from impacting the performance of the rest of my machine.

    #464
    Shades
    Participant

    Yeah it’s just about unplayable. I tried running it on an XP virtual machine and it still wasn’t running too great, I’ll try setting up a windows 2000 machine like you said. Thanks for the response!

    #481
    thejohnflournoy
    Participant

    You can try to run redmoon in compatibility mode for windows 7 or an older windows to see how that works. you would at least be able to play in windows mode.

    #492
    Shades
    Participant

    Update: RM Modder seemed to be the source of my issues on my XP machine. If you are having CPU load problems (game stuttering, slowing down periodically) uninstall your redmoon with the uninstaller in the directory and delete whatever is left over (should be RLEs and the client exe). Reinstall and move main.dll, rename main.windowed.dll to main.dll and just run that. Do NOT use RM Modder, or at least whichever function is causing the problem. Also – to run multiple clients do not create multiple folders, simply run the remoon.exe again from the same directory.

    THIS HAS FIXED MY LAG ISSUE ON XP

    going to try this on windows 8.1 and a windows 2000 virtual machine and put some more information in this post.

    Hopefully using the default windowed.dll + some compatibility tweaks will allow for this game to run on windows 8.1, I’ll keep you posted..

    EDIT: for those who may not know, in order to run windowed you must be in 16-bit color mode.

    Also – to eliminate the graphical issue with player names, (big font, pink/white names) disable ClearType in windows. This can be done by:

    A) Control Panel > System > Advanced > Performance, disable font smoothing

    -or-

    B) control panel > display > adjust ClearType settings (windows 7/8/8.1)

    • This reply was modified 5 years, 8 months ago by Shades.
    #521
    EKISHI
    Participant

    Im woundering if this game could perfectly run on on win8 either because Im going to buy new laptop in a few mouths.

    #522
    Shades
    Participant

    Haven’t found a great way yet tbh

    #538
    kostah
    Participant

    Hey,
    thanks for the useful info up there. I was able to run it on a virtual xp machine on windows 8. but how can i change the size of the window. why is it always 640×480?

    #539
    Shades
    Participant

    Are you talking about the size of the virtual machine window or the redmoon window? I’m not sure how to edit the size of the redmoon window but the virtual machine setting should be somewhere under the “view” toolbar. There should be a resolution setting there. Also, try changing the screen resolution within the virtual machine, it should adjust the window size.

    #541
    kostah
    Participant

    yeah i’m talking about the rm window. I can’t seem to figure it out.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.